sftp chroot_safe

Martin Nordin martin.nordin at gmail.com
Sun Dec 3 19:58:07 UTC 2006


Hello.

I've tried to follow the sftp + chroot_safe
tutorial<http://crux.nu/Main/ChrootSFTP>on the crux page but I can't
get it to work.

I can sftp/ssh to my machine as my usual user so I think the basic ssh/sftp
setup is ok.

I've followed the tutorial in minute detail but when I attempt to sftp as
the sftp-user the connection is cut immediately without error messages.

I've added my usual user to the /etc/sudoers exactly like the sftp usr and
when I run sudo /usr/lib/ssh/sftp-server-chroot I get this output:
Couldn't open /dev/null: No such file or directory

If I do a strace /usr/lib/ssh/sftp-server I can see that the sftp-server prg
performs an open(/dev/null) but when I have chrooted to the sftp usr home
dir the /dev/null is not there, of course.

Does anyone of you have any idea of what I'm doing wrong or how I can get
this to work?

Thanks,
Martin
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.crux.nu/pipermail/crux/attachments/20061203/1a223ef7/attachment.html>


More information about the CRUX mailing list