"crux-contrib" trouble

arnuld arnuld3 at gmail.com
Fri Dec 22 16:32:11 UTC 2006


hai all,

i wanted to use "user contributed" packages. so i did these 3 things:

1.) $ cd /etc/ports
2. $ mv contrib.rsync.inactive contrib.rsync
3.) edited /etc/prt-get.conf and uncommented the line "prtdir
/usr/ports/contrib" (i.e. removed the hashmark in the beginning of the
line. After that, it looked like this:

###
### prt-get conf
###

# note: the order matters: the package found first is used
prtdir /usr/ports/core
prtdir /usr/ports/opt

# the folloing line enables the user maintained contrib collection
prtdir /usr/ports/contrib
---------------------------------------

then i did "ports -u" & got this ERROR :-(

---------------------------------------------------------------------------------------------------------------------------

updating file list from crux.nu::crux-contrib
@ERROR: Unknow module 'crux-contrib'
rsync error: error starting client-server protocal (code 5) at main.c
(1296) [reciever]
Error: Running rsync failed()
Updating failed
Updating file list from crux.nu::ports/crux-2.2/core/
Updating collection ports/crux-2.2/core/
Finished successfully
Updating file list from crux.nu::ports/crux-2.2/opt/
Updating collection ports/crux-2.2/opt/
Finished successfully
---------------------------------------------------------------------------------------------------------------------------

i also tried:

# ports isinst rsync

it says:


[Config error : can't access /usr/ports/contrib]
package rsync is installed

what is the trouble? why it is not updating "contrib" packages?  i
also tried making a directory named "contrib" i.e.
"/usr/ports/contrib" even after doing that i get the same error :-(



-- 
arnuld
http://arnuld.blogspot.com/



More information about the CRUX mailing list