mouse does not work in X (SOLVED)

arnuld arnuld3 at gmail.com
Sun Dec 24 13:10:54 UTC 2006


> Earlier you said the mouse worked with the linux kernel for Gentoo.
> How much was different in the kernel you are now using? THe problem
> has to be in the kernel if you used the same X in both  cases. Do tell
> us when you find the answer - these are such annoying problems,

i reinstalled CRUX & found that CRUX by default does not enable the
mouse. one *has to* enable mouse support before compiling kernel
(after "make menuconfig") in "Input Devices" section. CRUX *assumes*
user will not use a mouse ;-)

BTW, "Gilles Dassac" was talking about setting mouse  device to
"/dev/psaux" rather than to "/dev/input/mice" & said it resolved the
same trouble for him. he also said that one has to enable it in kernel
before compiling but on the contrary i have found that "psaux" was
enabled by default whereas "mouse" was not.

after reinstallation with new kernel options it is working now :-) but
now i am not able to install GNOME but that i will discuss in another
thread.
> merry xmas

hey thanks :-) & same to you

> clare

i am not a Native English-man. i am confused whether you are a boy or a girl ?

just asking ....



-- 
arnuld
http://arnuld.blogspot.com/



More information about the CRUX mailing list