php5 build fails (--with-apxs2)

Juergen Daubert jue at jue.li
Wed Nov 1 17:13:36 UTC 2006


On Wed, Nov 01, 2006 at 06:04:00PM +0100, Theo Kanter wrote:
> Following the guidelines in
> http://www.php.net/manual/en/install.unix.apache2.php
> I thought I might add PHP5 support to Apache 2. Apache runs fine. Php 
> builds without the --with-apxs2 option. However when I added  
> '--with-apxs2=/usr/sbin/apxs \' to the Pkgfile the
> php build fails ending with:
> 
> 	[stuff deleted]
> 	Build complete.
> 	(It is safe to ignore warnings about tempnam and tmpnam).
> 
> 	+ install -D -m 755 sapi/cgi/php 
> 	/usr/ports/contrib/php/work/pkg/usr/bin/php
> 	install: cannot stat `sapi/cgi/php': No such file or directory
> 	=======> ERROR: Building 
> 	'/usr/ports/contrib/php/php#5.1.6-1.pkg.tar.gz'
> 	failed.
> 	bash-3.1#
> 
> I am without clues and cannot find a hint that works on the php forums or 
> elsewhere. Thanks,
> --theo
> 

you probably want opt/mod_php.

HTH
Juergen

-- 
Juergen Daubert  |  mailto:jue at jue.li  
Korb, Germany    |  http://jue.li/crux




More information about the CRUX mailing list