Gnome install script fails with vte and a missing XML::Parser

Mark Rosenstand mark at borkware.net
Wed Oct 4 21:08:46 UTC 2006


On Wed, 2006-10-04 at 21:31 +0200, Theo G. Kanter wrote:
> Followed the instruction in the FAQ for installing Gnome on CRUX. Exellent
> guidelines but the install script fails with vte:
> 
> [stuff deleted]
> checking for perl... /usr/bin/perl
> checking for XML::Parser... configure: error: XML::Parser perl module is
> required for intltool
> =======> ERROR: Building '/usr/ports/contrib/vte/vte#0.13.0-1.pkg.tar.gz'
> failed.
> -- Packages where install failed
> vte
> Press <ENTER> to continue ..
> 
> So somehow it is related to Perl not knowing where its XML::Parser is:
> 
> bash-3.1# /usr/bin/perl -e "require XML::Parser"
> Can't locate XML/Parser.pm in @INC (@INC contains:
> /usr/lib/perl5/5.8.8/linux /usr/lib/perl5/5.8.8
> /usr/lib/perl5/site_perl/5.8.8/linux /usr/lib/perl5/site_perl/5.8.8
> /usr/lib/perl5/site_perl .) at -e line 1.
> 
> The only Parser.pm found is in another subdirectory, not mention in @INC:
> 
> bash-3.1# find /usr -name Parser.pm -print
> /usr/lib/perl5/5.8.8/Pod/Parser.pm
> 
> Could someone please guide me as to how to
> a) fix this Perl XML::Parser problem?
> b) run the rest of the Gnome script or should I just rerun it?

IIRC, p5-xml-parser is in jaeger's gnome repo. If you already have it
installed, you could try to rebuild it (since perl has this braindead
feature that modules are installed in a versioned directory even for
micro versions, so every time you upgrade perl, you'll have to reinstall
all your modules...)




More information about the CRUX mailing list