Gnome install script fails with vte and a missing XML::Parser

Theo Kanter kanter at kth.se
Thu Oct 5 07:22:01 UTC 2006


Hitoshi Satow wrote:
> p5-xml-parser is also in the opt repository..
>
> I had the same problem with another port.  That should fix the problem.
Thank you, it did!

Then vte said it needed python, which yapo confirmed was not installed. 
Now I have both /usr/lib/python and /usr/lib/python2.4 for some 
unfathomable reason.And vte complained at the end of the build about 
missing python footprint:

=======> ERROR: Footprint mismatch found:
MISSING   drwxr-xr-x      root/root       usr/lib/python2.4/
MISSING   drwxr-xr-x      root/root       usr/lib/python2.4/site-packages/
MISSING   drwxr-xr-x      root/root       
usr/lib/python2.4/site-packages/gtk-2.0/
MISSING   -rw-r--r--      root/root       
usr/lib/python2.4/site-packages/gtk-2.0/vtemodule.a
MISSING   -rwxr-xr-x      root/root       
usr/lib/python2.4/site-packages/gtk-2.0/vtemodule.la
MISSING   -rwxr-xr-x      root/root       
usr/lib/python2.4/site-packages/gtk-2.0/vtemodule.so
=======> ERROR: Building 
'/usr/ports/contrib/vte/vte#0.13.0-1.pkg.tar.gz' failed.

I was able to install vte with pkgmk -i, but I am still confused about 
the missing python footprint and ending up with two identical python 
directories in /usr/lib. Currently running the gnome install script from 
http://crux.nu/Main/GnomePorts again.

--theo





More information about the CRUX mailing list