Python 2.5

Juergen Daubert jue at jue.li
Thu Oct 5 16:09:18 UTC 2006


Hi all,

because there was some rumor on #crux and I got some private 
email's as well, I would like to clarify some points regarding 
Python 2.5.

Python 2.5 is a major release not compatible with 2.4.x. 
Updating to it means at least, that all dependent ports have to 
rebuild, which is IMO not acceptable without a release change
of CRUX. Therefore this update will not come before CRUX 2.3.

For those who need, for whatever reason, Python 2.5 short-term 
I've prepared a port [1] in my private repository. For now the 
port depends on sqlite3 [2], because the wrapper is part of the
python sources. Though, I tend to remove this dependency for the 
final, official opt port.  


kind regards
Jürgen


[1] httpup sync http://jue.li/crux/ports/#python python
[2] httpup sync http://jue.li/crux/ports/#sqlite3 sqlite3

-- 
Juergen Daubert  |  mailto:jue at jue.li  
Korb, Germany    |  http://jue.li/crux




More information about the CRUX mailing list