Gnumeric

Wawrzyniec Niewodniczański wawrzyniec.niewodniczanski at pwr.wroc.pl
Sat Oct 7 10:47:00 UTC 2006


Hello,

I tried to install gnumeric and found some bugs.

1.) (it not a bug) in ports it is 1.4.3 version, but the newest is
1.7.1. (1.7.1 is in hnc repo).

2.) You cannot build 1.4.3 because abi of libgsf has been changed. (I
found some info at [1])

"gog-axis.c:1683:58: error: macro "GSF_CLASS_FULL" requires 10 arguments,
but only 7 given
gog-axis.c:1686: error: syntax error before 'GogAxisType'" [2]

I change the version to 1.7.1 but the configure complains about 

No package 'libgoffice-0.3' found
Requested 'libgsf-1 >= 1.14.2' but version of libgsf-1 is 1.14.0
No package 'libgsf-gnome-1' found

libgoffice can be found in goffice [3] package by hnc [3].
I change libgsf version to 1.14.2 and build if without any problems.
It quite interesting but there is no libgsf-gnome-1 in hnc repo.

I changed the Pkgfile for libgsf package (building with  gnome support):
    ./configure --prefix=/usr \
        --disable-gtk-doc

Gnumeric configure worked ok, but its make died:

make[2]: Entering directory `/media/inny/tmp/work/src/gnumeric-1.7.1'
make[2]: *** No rule to make target `po/am.po', needed by
`gnumeric.desktop'.  S                                        top.


Do you have any suggestion?

Wawrzek


[1] http://frugalware.org/~xbit/irclog/3-0-9-11-2005.html
[2] http://paste.lisp.org/display/24678
[3] http://crux.nu/portdb/?command=viewport&repo=hnc&name=goffice
[4] http://crux.nu/portdb/?command=viewrepo&name=hnc

-- 
Wawrzyniec Niewodniczański        WWW: http://larryn.blogspot.com/
    vel LarryN           E-MAIL: wawrzyniec.niewodniczanski[na]pwr.wroc.pl
PhD student @                           JID: larryn at chrome.pl                
Wroclaw University of Technology        TEL: +48(071)320-2894




More information about the CRUX mailing list