problems with EPIA M

Clemens Koller clemens.koller at anagramm.de
Sun Aug 12 16:34:57 UTC 2007


Hello, Nikolai!

fikin schrieb:
>  >Well, the CD isn't broken, Nikolai?
> it is ok.
> this is most peculiar indeed.
> 
> i've spent quite some time with this, basically booting, trying various 
> options and again. also i was testing with another motherboard: via 
> kt333 (featuring vt8233 chipset).
>
> first error comes only under epia motherboard.
> and the bazaar think is that occasionally it would work fine. no 
> explanations on my side.
> 
> second error is a due to failed bunziping of the kernel tar (which btw 
> does not alter setup's exit status, errors are only mentioned in the log 
> file).

Did you check your memory with memtest86?
Please post the dmesg output of the failing kernel.

> this error is reproducible reliably on both motherboards. no exceptions.
> if it wasn't  for qemu i'd claim a broken tar file is used.

I just tried a standard CRUX-2.2 once within qemu... about a year ago.
It just worked.

> is there something special about via support in crux installation kernel?

There is no intention to do something special there. It's just a plain vanilla
kernel, configured for some more or less standard i686(i585) configurations.
Your EPIA M might not be standard enough for that case.
IIRC there are some config options for some VIA Cx CPU's.

As mentioned, I would try the latest kernel. Use a minimum configuration
and post the dmesg output to the list if possible.
I (or you) can also check with some guys at the linux kernel mailing
list (LKML) if you are running into troubles with a current kernel.

[10mins later]
Okay, I checked some list archives (Note: This information is second hand, YMMV):

- There are patched -epia kernels out there... so there is something special.

- Some VIA CPUs are detected as i686 CPUs which is basically fine because
they have the i.e. 3dnow and mmx instructions, however they are missing the "cmov"
instructions, which might also get used by the glibc...
The following compile options should be fine for "VIA-Boards", (I think that
should read "VIA-CPUs"):

CFLAGS="-march=i586 -m3dnow -mmmx -Os -pipe"
CHOST="i586-pc-linux-gnu"

- Try the kernel options: apm=off and acpi=off

- see: http://linux.derkeiler.com/Mailing-Lists/Kernel/2003-08/2745.html

So your system seems to be indeed special and needs some manual work to
get it running if you want to use a i686 distro.
And fixing your kernel might not fix your system, if you have your
binaries using some stuff your CPU can't deal with.
(Maybe the CRUX-2.3-i586 isn't i586'ish enough?)

For further reference, see: http://witch.muensterland.org/stories/27.html

Regards,
-- 
Clemens Koller
_______________________________
R&D Imaging Devices
Anagramm GmbH
Rupert-Mayer-Str. 45/1
81379 Muenchen
Germany

http://www.anagramm-technology.com
Phone: +49-89-741518-50
Fax: +49-89-741518-19



More information about the CRUX mailing list