Perl Problems

Mikhail Kolesnik mike at openbunker.org
Sat Feb 10 19:02:36 UTC 2007


Sorry for off-topic, but maybe you can point a pretty way to have both
'libperl.a' and 'libperl.so' installed from one build. Current core/perl
has only 'libperl.a'. Some distributions seems to solve that by
running make 2 times (one time with "-Duseshrplib=true", second -
without) and putting things together, others just use a shared
version.

For example, having a shared library is essential to compile
latest net-snmp with "--enable-embedded-perl" (which stops me from
updating contrib/net-snmp). Other uses may arise.

See the bug #152[1] for the possible solution.

[1] https://crux.nu/bugs/?do=details&id=152

-- 
Mikhail Kolesnik
ICQ: 260259143
IRC: mike_k at freenode/#crux, rusnet/#yalta



More information about the CRUX mailing list