virtualbox for crux 2.5

Jose V Beneyto sepen at users.sourceforge.net
Mon Dec 8 18:34:02 UTC 2008


Hi,

virtualbox fails to compile for 2.5 due to gcc:
[...]
+ ./configure --disable-qt3 --with-qt4-dir=/usr/share/qt4 
--disable-hardening --ose --disable-pulse
Checking for environment: Determined build machine: linux.x86, target 
machine: linux.x86, OK.
Checking for kBuild: found, OK.
Checking for gcc:
  ** There are known problems with gcc version 4.3 when compiling the 
recompiler
  ** stuff. You need to specify a compatibility compiler with version < 
4.3. Look
  ** for a package compat-gcc-34 on Fedora systems or something similar 
on other
  ** distributions and call configure with parameter 
--with-gcc-compat=gcc34.
[...]

I installed contrib/gcc34 and modified the vbox port from 2.4: 
http://mikeux.dyndns.org/crux/files/virtualbox-crux2.5.diff

Also I experienced some problems when the configure scripts checks for 
python stuff (python2.6), I removed the check_python invocation to see 
if the gcc43 error disapears, and seems it does the trick.

Suggestions are welcome. Thanks,
    Jose V Beneyto



More information about the CRUX mailing list