clisp and texlive

Ian Hoffman hoffman.ian.m at gmail.com
Wed Nov 14 20:50:25 UTC 2012


Hi, all.

 I am a long-time CRUX user; thank you all for your efforts in
contributing to a great distribution.

 I recently upgraded to 2.8 on my x86_64 via binaries from the CD.  I
am trying to build texlive and its dependencies, but I am failing on
clisp.  My system is otherwise totally healthy.  Here is the pertinent
end of the build log

<quote>

gcc -DHAVE_CONFIG_H -I. -I..  -I../intl   -O2 -march=x86-64 -pipe -W
-Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type
-Wmissing-declarations -Wno-sign-compare -Wno-format-nonliteral -O
-falign-functions=4 -DENABLE_UNICODE -DDYNAMIC_FFI -DDYNAMIC_MODULES
-I. -fPIC -MT uniwidth/width.o -MD -MP -MF $depbase.Tpo -c -o
uniwidth/width.o uniwidth/width.c &&\
mv -f $depbase.Tpo $depbase.Po
rm -f libgnu.a
ar cru libgnu.a localcharset.o strnlen1.o uniname/uniname.o uniwidth/width.o
ranlib libgnu.a
make[3]: Leaving directory `/usr/ports/opt/clisp/work/src/clisp-2.49/src/gllib'
make[2]: Leaving directory `/usr/ports/opt/clisp/work/src/clisp-2.49/src/gllib'
make[1]: Leaving directory `/usr/ports/opt/clisp/work/src/clisp-2.49/src/gllib'
=======> ERROR: Building '/usr/ports/opt/clisp/clisp#2.49-1.pkg.tar.gz' failed.
prt-get: error while install

</quote>

I can't build clisp by hand from the source, either.  Nor can I build
texlive with clisp disabled.

Any thoughts?

I am not above using a 64-bit clisp binary, if anybody can point me to
one ... my rpm2targz is failing on the other packages I have found...

-Thanks, Ian



More information about the CRUX mailing list