Is it possible to use pusleaudio in crux?

Stefan Stefanov selectany at gmail.com
Fri Nov 23 15:24:16 UTC 2012


Ok, I found some kind of automation (but not tried yet).
1. for i in $(find / -type f -name "*.so" -print0 2>/dev/null | xargs
-0 grep 'libpthread-stubs.so.0' | cut -d' ' -f3); do prt-get fsearch
`basename $i` | grep 'Found'; done | sort -u | sed "s/\(.*\)./\1/" |
sed "s/.*\///"

2. prt-get update -fr -if -im `prt-get quickdep <package>`


First batch of commands finds all packages need to be rebuilt.
Second one rebuild each of those packages and all its dependencies.


PP: I must repeat 1. and 2. for binaries in /usr/bin

2012/11/23 Stefan Stefanov <selectany at gmail.com>:
> Donald Cupp points me to the resolution of the problem i.e. removing
> libpthread-stubs.so.0 from my system.
> This could be done be upgrading the package (libpthread-stubs) from
> 0.2 to 0.3 version.
> After moving to 0.3 version libpthread-stubs.so.0 is gone, but there
> are many the dependency on libpthread-stubs,so.0.
>
> At the beginning the whole xorg must be rebuilt, but this is not the
> end of the story :)
>
> My DE still refuses to start (with startx) with errors of missing
> libpthread-stubs.so.0 file (for example dbus).
>
> I need the some kind of automation to rebuild remaining packages which
> still rely on libpthread-stubs.so.0.
>
> I use this commands to find all binaries which still need libpthread-stubs:
>
> for i in $(find / -type f -name "*.so" -print0 2>/dev/null | xargs -0
> grep 'libpthread-stubs.so.0' | cut -d' ' -f3); do echo $i; done >
> stubs_deps.txt
>
> My question: How to print all packages (not just files as upper
> commands do) which need to be rebuilt (and probably include the build
> commands)?
>
> 2012/11/22 Stefan Stefanov <selectany at gmail.com>:
>> The problem with pulseaudio is that crux use libpthread-stubs.so
>> instead libpthread.so from libc.
>> Thus, causes puseaudio to hangs in sem_wait() function from libpthread-stubs.so.
>>
>> I can see that other distros doesn't use libpthread-stubs.so and they
>> rely entirely on libpthread.so.
>>
>> Obviously libpthread-stubs.so cause problem in my case, but I cannot
>> just remove it.
>> If I remove it, pusleaudio complains that this library is missing and
>> I don't understand how to make pulseaudio to link against
>> libpthread.so instead libpthread-stubs.so.
>>
>> My question is how to make transition from libpthread-stub.so to
>> libpthread.so and completely remove libpthread-stubs.so?
>>
>> 2012/11/19 Matt Housh <jaeger at morpheus.net>:
>>> On 11/18/2012 06:54 AM, Stefan Stefanov wrote:
>>>> Hello
>>>>
>>>> I spend several days trying to make pulseaudio works, but without
>>>> success. Pulseaudio starts without errors, but it is not responding.
>>>> If I run "pacmd list" (or some other pulseaudio related cli tool),
>>>> all I get is "Daemon not responding".
>>>>
>>>> The big problem is that there is no error messages in log files
>>>> about pulseaudio and it seam that pulseaudio works but it isn't.
>>>>
>>>> Log messages only contains info messages about pulseaudio start
>>>> process.
>>>>
>>>> I think that the real problem could be misconfigured permissions.
>>>
>>> Hello, Stefan,
>>>
>>> I don't think there are many PulseAudio users in CRUX (myself included)
>>> so you might have trouble getting help for it here. With that said, have
>>> you looked for extra debugging options for the daemon itself?
>>> Alternatively, running it in the foreground with strace? Perhaps one of
>>> those would give you some useful information.
>>>
>>> Good luck,
>>> Matt
>>>
>>> _______________________________________________
>>> CRUX mailing list
>>> CRUX at lists.crux.nu
>>> http://lists.crux.nu/mailman/listinfo/crux



More information about the CRUX mailing list