nfs-utils package (nfs server) without kerberos/gss but supporting nfs version 4?

Thierry Moreau thierry.moreau at connotech.com
Fri Jan 25 00:28:04 UTC 2013


Hi!

Attempting to install an NFS server on a Crux 2.8 box, I notice from the 
Pkgfile that the configure options include --disable-gss (i.e. no 
Kerberos dependency) but including neither --disable-nfsv4 nor 
--disable-nsfv41 (thus presumably supporting NFS versions 4, 4.1).

This seem to imply a limited security model: wouldn't the kerberos model 
be the typical one for NFS version 4? Would the kerberos package be the 
only additional dependency with --enable-gss=yes (the default)?

Also, the kernel support of keys (CONFIG_KEYS in .config) might be 
required for an NFS version 4 server in either security model -- I'm not 
sure.

My only suggestion is that a short README file in ports/opt/nfs-utils 
could explain these two points. I am not confident enough to propose 
some text, sorry.

Best regards, and thanks again for the Crux distributions!

-- 
- Thierry Moreau

CONNOTECH Experts-conseils inc.
9130 Place de Montgolfier
Montreal, QC, Canada H2M 2A1

Tel. +1-514-385-5691



More information about the CRUX mailing list