Cups-filters-1.2.0 fails to build on Crux-3.2

Hazel Russman hazeldebian at googlemail.com
Sun Dec 13 11:33:21 UTC 2015


> Message: 3
> Date: Thu, 10 Dec 2015 12:39:55 +0000
> From: David Brooke <crux at dbrooke.me.uk>
> Subject: Re: cups-filters-1.2.0
> To: crux at lists.crux.nu
> Message-ID: <20151210123955.GB14247 at cubitt.dbrooke.me.uk>
> Content-Type: text/plain; charset=us-ascii
> 
> On Thu, Dec 10, 2015 at 12:23:08PM +0000, Hazel Russman wrote:
> > 
> > There are pages of these errors. They occur when pdftopdf is being linked by CXXLD.
> 
> I'm not entirely sure if this is relevant to your circumstances but I
> have found that, following an upgrade from 3.1 to 3.2, it has in some
> cases been necessary to rebuild some dependencies of a port.
> 
> The folowing is likely to do more than strictly necessary but should
> rebuild all dependencies:
> 
> prt-get update -fr $(prt-get quickdep <port>)
> 
> David
> 
The error messages suggested that it was qpdf that was causing the trouble so I just rebuilt that. In the meantime opt/cups-filters has been upgraded to 1.3.0 which built successfully. So now I shall never know if it was rebuilding qpdf that solved the problem or if there was a bug in 1.2.0 that got cleared;-)

-- 
H Russman



More information about the CRUX mailing list