Crux boot-up time error

bobby architectofthefuture at gmail.com
Mon Nov 12 00:46:01 UTC 2018


Tried that, and it tells me no such image still.

On Sun, Nov 11, 2018 at 5:27 PM Fredrik Rinnestam <fredrik at rinnestam.se>
wrote:

> On Sun, Nov 11, 2018 at 05:20:31PM -0700, bobby wrote:
> > I did that, and it returned:
> > "No such image.  [Tab] shows a list.".
> > When I do [tab], it returns CRUX, which puts me at where I started.
>
> Try something like image=/boot/vmlinuz append="root=/dev/xvda1"
>
>
>
> > On Sun, Nov 11, 2018 at 5:14 PM Fredrik Rinnestam <fredrik at rinnestam.se>
> > wrote:
> >
> > > On Sun, Nov 11, 2018 at 05:06:54PM -0700, bobby wrote:
> > > > It seems I am using LILO, because when I hold down shift to get into
> > > single
> > > > user mode it gives me this prompt:
> > > > LILO boot:
> > > > How do I enter single user mode via this?
> > >
> > > According to https://www.tldp.org/HOWTO/html_single/LILO/#ss2.3
> > >
> > > you can probably just enter root=/dev/xvda1 (I'm just guessing here
> > > according to what your initial screenshot suggested)
> > >
> > > /f
> > >
> > > > On Sun, Nov 11, 2018 at 5:05 PM Fredrik Rinnestam <
> fredrik at rinnestam.se>
> > > > wrote:
> > > >
> > > > > On Sun, Nov 11, 2018 at 04:54:51PM -0700, bobby wrote:
> > > > > > Where is the bootloader conf file located at?
> > > > >
> > > > > Depends on what bootloader you use. If its lilo you should have a
> > > > > /etc/lilo.conf file. You then run 'lilo' to write the changes to
> the
> > > > > bootsector.
> > > > >
> > > > > grub uses /boot/grub/grub.cfg and looks at the config each time you
> > > > > boot. So no need to do anything else.
> > > > >
> > > > > /f
> > > > >
> > > > > > > >
> > > > > > > > VFS: unable to mount root fs is due to the kernel not having
> the
> > > > > device
> > > > > > > > driver for the root filesystem built in to it or not having
> the
> > > > > device
> > > > > > > > driver for the disk bus built in.
> > > > > > > >
> > > > > > > > I imagine that xcp-ng, whatever that is, presents different
> > > devices
> > > > > to
> > > > > > > the
> > > > > > > > virtual guest than virtualbox did.
> > > > > > > >
> > > > > > > > -Daryl
> > > > > > >
> > > > > > > From what I can tell it just looks like the root= needs to be
> > > adjusted
> > > > > > > in the bootloader. root=xvda1 perhaps?
> > > > > > >
> > > > > > > Not at all familiar with xenserver so forgive my ignorance.
> > > > > > >
>
> --
>
> Fredrik Rinnestam
> _______________________________________________
> CRUX mailing list
> CRUX at lists.crux.nu
> https://lists.crux.nu/mailman/listinfo/crux
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.crux.nu/pipermail/crux/attachments/20181111/1a2d9d68/attachment-0001.html>


More information about the CRUX mailing list