Rust: update failed

Cédric rainbow at indie.host
Mon Feb 25 22:13:35 UTC 2019


Hello,

I get an error with the update of the last firefox version, it's related
to the version of rust which is too old. I get the following when I try
to update rust:

#local-rebuild = true
+ export CARGO_HOME=/usr/ports/opt/rust
+ CARGO_HOME=/usr/ports/opt/rust
+ export 'RUSTFLAGS= -C link-args=-lffi'
+ RUSTFLAGS=' -C link-args=-lffi'
+ /usr/bin/python3 ./x.py build
--config=/usr/ports/opt/rust/work/src/config.toml --exclude src/tools/mi
info: looks like you are running this command under `sudo`
      and so in order to preserve your $HOME this will now
      use vendored sources by default. Note that if this
      does not work you should run a normal build first
      before running a command like `sudo ./x.py
      install`

error: failed to parse manifest at
`/usr/ports/opt/rust/work/src/rustc-1.32.0-src/src/tools/clippy/Cargo

Caused by:
editions are unstable

Caused by:
feature `edition` is required

consider adding `cargo-features = ["edition"]` to the manifest
failed to run: /usr/bin/cargo build --manifest-path /usr/ports/opt/rust/work/src/rustc-1.32.0-src/src/bootstrap/Cargo.toml --frozen
Build completed unsuccessfully in 0:00:00
=======> ERROR: Building '/usr/ports/opt/rust/rust#1.32.0-1.pkg.tar.gz' failed.

Am I the only one or should I write a bug report ? I don't know rust and
I don't know if the problem is on my system or not.

Thank you!

Best regards,

Cédric


More information about the CRUX mailing list