Orphans after qt4

Fredrik fredrik at rinnestam.se
Sun Sep 15 22:34:07 UTC 2019


On 9/16/19 12:28 AM, Wawrzek Niewodniczanski wrote:
> Hi,
> I think we need to kick a few more ports following removal of qt4:
> 
> # prt-get  dependent  --all qt4
> pinentry-qt4
> xpdf
> scribus
> keepassx
> vlc
> keepassx2
> hedgewars
> smtube
> opera
> fbreader
> smplayer
> qjson

Most (if not all) will work with qt5 after a rebuild. I only use
smplayer on that list but it works just fine with qt5.

> And maybe libechonest (and then clementine). I have a strange problem:
> 
> "-- Could not find Qt5, searching for Qt4 instead...
> CMake Error at /usr/share/cmake/Modules/FindQt4.cmake:1314 (message):
>   Found unsuitable Qt version "" from NOTFOUND, this code requires Qt 4.x
> Call Stack (most recent call first):
>   CMakeLists.txt:38 (find_package)
> "
> but:
> 
> "
> # prt-get install qt5
> package qt5 is installed
> "
> 
> Wawrzek
> 



More information about the CRUX mailing list