ports/contrib (3.6): [notify] pulseeffects: 4.8.4 -> 5.0.3; now requires pulseaudio over pipewire, updated README.md

crux at crux.nu crux at crux.nu
Sun May 9 12:17:56 UTC 2021


commit 0b9c730d7d2af0cb8e76de531d1928a36797ed8e
Author: Tim Biermann <tbier at posteo.de>
Date:   Sun May 9 12:05:38 2021 +0000

    [notify] pulseeffects: 4.8.4 -> 5.0.3; now requires pulseaudio over pipewire, updated README.md

diff --git a/pulseeffects/.signature b/pulseeffects/.signature
index a0583f3b1..c9354b586 100644
--- a/pulseeffects/.signature
+++ b/pulseeffects/.signature
@@ -1,5 +1,5 @@
 untrusted comment: verify with /etc/ports/contrib.pub
-RWSagIOpLGJF3ySkDyYF3weDzM/loHSacGoCZt2fkXw8bjSlp1bfh6/tuqWgd0A1LsxrSQsU3J27cwXAFcAeSoDj/Ut/3EoQIwc=
-SHA256 (Pkgfile) = a13a928227182be1a83e6b859d439408e39a5ed43ebb5d56f605d15e002f149b
+RWSagIOpLGJF3/bQmA/0uc54FOOqC52+nLXDeimhxKX3BnvrMZ9yAP2U/Sud49Lhw3qJLUvrXLYMTVmMF4GxlAEfy7LQg4XbawM=
+SHA256 (Pkgfile) = 6593ae19d098abfdf78e88794bc581924c5e88135985a9a42d32263f341a8a06
 SHA256 (.footprint) = b46a0aef9bb11abceb0ad835763d9b3b1368241fb4880ee51ef26c02360ce84c
-SHA256 (pulseeffects-4.8.4.tar.gz) = 12ba3205025d815a747b58636861594f7d1e43a578a5b0411f7794f4c12e5d86
+SHA256 (pulseeffects-5.0.3.tar.gz) = 2e14858918b54bee5f6e4898cc803ae2170b4d624407fef39e0831b6584c4a4f
diff --git a/pulseeffects/Pkgfile b/pulseeffects/Pkgfile
index e63c10855..8ffd74911 100644
--- a/pulseeffects/Pkgfile
+++ b/pulseeffects/Pkgfile
@@ -1,19 +1,18 @@
 # Description: Audio Effects for Pulseaudio Applications
 # URL: https://github.com/wwmm/pulseeffects
 # Maintainer: Tim Biermann, tbier at posteo dot de
-# Depends on: boost cairomm12 desktop-file-utils gst-plugins-bad gtkmm3 itstool libebur128 pulseaudio
-# Optional: calf mda.lv2 rubberband vamp-plugin-sdk zam-plugins zita-convolver libbs2b lilv
+# Depends on: boost desktop-file-utils gst-plugins-bad gtkmm3 libebur128 pipewire pulseaudio
+# Optional: calf libbs2b lilv mda-lv2 rnnoise rubberband vamp-plugin-sdk zam-plugins zita-convolver
 
 name=pulseeffects
-version=4.8.4
+version=5.0.3
 release=1
-source=(https://github.com/wwmm/pulseeffects/archive/$version/$name-$version.tar.gz)
+source=(https://github.com/wwmm/pulseeffects/archive/v$version/$name-$version.tar.gz)
 
 build() {
   meson setup $name-$version build \
     --prefix=/usr \
-    --sysconfdir=/etc \
-    --buildtype=plain
+    --sysconfdir=/etc
   meson compile -C build
   DESTDIR=$PKG meson install -C build
   rm -fr $PKG/usr/share/{locale,help}
diff --git a/pulseeffects/README b/pulseeffects/README
deleted file mode 100644
index a239bb264..000000000
--- a/pulseeffects/README
+++ /dev/null
@@ -1,23 +0,0 @@
-About the optional dependencies (list borrowed from arch):
-calf - limiter, compressor, exciter, bass enhancer, and others
-lsp-plugins - equalizer
-mda.lv2 - loudness
-rubberband - pitch shifting
-
-You will need to rebuild gst-plugins-bad after installing any of the optional
-dependencies, pulseeffects will then pick them up and make them available,
-otherwise, all the plugins are shown but none of them are useable.
-
-If you run into issues, please try removing GStreamer's cache `rm -rf ~/.cache/gstreamer-1.0`
-and have a look at the debug output with `G_MESSAGES_DEBUG=pulseeffects pulseeffects`
-
-You can check what plugins your current gstreamer build offers with
-`gst-inspect-1.0 | grep -i calf | grep -i limiter`
-
-Additional info from the official FAQ over at https://github.com/wwmm/pulseeffects/wiki/FAQ
-
-Question 13 - After turning on effects for an application my master volume is set to 100 %.
-
-Answer: Take a look at the output of the command pulseaudio --dump-conf and
-see if you have the option flat-volumes set to yes instead of no. For more
-information take a look at #346: https://github.com/wwmm/pulseeffects/issues/346
diff --git a/pulseeffects/README.md b/pulseeffects/README.md
new file mode 100644
index 000000000..238fa0fc0
--- /dev/null
+++ b/pulseeffects/README.md
@@ -0,0 +1,65 @@
+# contrib/pulseeffects README
+
+## Building pulseeffects
+
+Building and successfully using pulseeffects requires you to build pipewire
+including pulseaudio support. Therefor, pulseaudio needs to be around before
+you install pipewire. After that, pulseeffects can be successfully installed
+and used.
+
+It's recommended to set the following setting in `/etc/pkgmk.conf`:
+```sh
+PKGMK_IGNORE_NEW="yes"
+```
+This will ignore any *new* files found a footprint. This is needed, because
+it's expected to produce more files than a minimal build for some individual
+ports, e.g. `contrib/pipewire`, `contrib/gst-plugins-bad`, etc..
+
+Another setting to consider is the following in `/etc/prt-get.conf`:
+```sh
+runscripts yes
+```
+Alternatively, you will need to watch out for ports that would run
+pre-/post-install scripts yourself and execute them in order to expect a
+fault-free environment.
+
+After considering those stepts, if you manually want to ensure that everything
+will be fine, the steps should be as followed:
+ 1. `prt-get depinst pulseaudio`
+ 2. `prt-get depinst pipewire`
+ 3. `prt-get depinst pulseeffects`
+
+Please take a look at `contrib/pipewire/README` for more instructions on how
+to setup a pipewire environment. Make sure to enable it for handling
+`pulseaudio` requests and you are good to go.
+
+## Optional dependencies:
+About the optional dependencies (list borrowed and enhanced from archs
+[PKGBUILD](https://github.com/archlinux/svntogit-community/blob/packages/pulseeffects/trunk/PKGBUILD)
+):
+ * calf - limiter, compressor, exciter, bass enhancer, and others
+ * lsp-plugins - equalizer
+ * mda.lv2 - loudness
+ * rubberband - pitch shifting
+ * rnnoise - noise supression using a recurrent neural network
+ * zam-plugins: maximizer
+
+You will need to rebuild gst-plugins-bad after installing most of any of
+those optional dependencies, pulseeffects will then pick them up and make
+them available, otherwise, all the plugins are shown but none of them are
+useable.
+
+## Issues
+ - If you run into issues, please try removing GStreamer's cache
+`rm -rf ~/.cache/gstreamer-1.0` and have a look at the debug output with
+`G_MESSAGES_DEBUG=pulseeffects pulseeffects`.
+ - You can check what plugins your current gstreamer build offers with
+`gst-inspect-1.0 | grep -i calf | grep -i limiter`
+
+## Additional information
+Additional info from the official FAQ over at the projects
+[official wiki](https://github.com/wwmm/pulseeffects/wiki/FAQ)
+
+// vim:filetype=markdown
+
+// End of file


More information about the CRUX mailing list