[SPAM?? (MM)]::[Clc-crux64] crux64 runs great so far

Jeremy Jones jjones at djc.state.id.us
Wed May 25 14:02:16 UTC 2005


Hi Ron,

On Wed, 2005-05-25 at 00:16 -0700, Ron Young wrote:
> I just installed crux64 . Everything is running great some far. I moved up
> to 2.6.12-rc4-git7.

Glad to hear it's working for you!

> I took out the -fPIC flag and everything I have build so far installed fine.
> So I don't know when its required.

I'm afraid you may find down the road that software will complain about
shared libraries & being unable to relocate, blah, blah, blah.  In that
case, you might need to find the library that the software is
complaining about, figure out what to which package it belongs, and
recompile that package with -fPIC in the C{XX}FLAGS.

> I installed the Nvidia driver ,alsa utils,beep,xfce4,lm-sensors.

Great.  I know I promised a while back to set up an httpup ports
repository for contrib on x86_64...  Might be a while out yet, but if
you find there's something you can't get compiled out of contrib, ask
me, I may have a modified port to loan you.

> The sensors are reading correctly and the sound is great. Glxgears runs
> about 7500 frames/sec. Card is a evga6600GT. I haven't played with any
> options to try to get to run faster.
> 
> The only trouble I've had is some the ports ( gkrellm ) and the xfce4
> graphical installer can't find the X11 libraries. What do I do to fix that??

When you get those, try one of the following:

1) add to pkgmk.conf a line like this:

	LDFLAGS="-L/usr/X11R6/lib64 $LDFLAGS"

2) add at the top of the build section of your Pkgfile:

	export LDFLAGS="-L/usr/X11R6/lib64 $LDFLAGS"

> So far this is the smoothest distro install I've had. Great job.

Thanks!  I'm really glad people are finding it useful.

Jeremy




More information about the crux64 mailing list